Symptom
The Code 25h error indicates a fault with the brake inhibitor sensors.
Possible Causes
- Overly tight sensor
- Damaged, broken, or corroded connections
Troubleshooting Steps
For assistance with finding and adjusting the brake inhibitors, please watch the video attached at the end.
- Locate and unplug the brake inhibitor wires in the front of your bike. When unplugged, the internals should be red with two pins.
- Damaged pins and/or cables. If the insides of the connectors appear damaged, take photos and Submit a Warranty Claim or Start a Ticket for Assistance. If the connectors look normal, continue to the next step.
- Test other functions. While the brake inhibitors are unplugged, test whether the throttle, walk assist, and pedal assist still work. If the throttle, walk assist, and pedal assist still work while the brake inhibitors are unplugged, at least one of the brake inhibitors is confirmed to be causing the error.
- Test each Brake Inhibitor separately. Now reconnect one of the brake inhibitors and repeat step #3. Once done, disconnect that inhibitor, connect the other one, and again repeat step #3. This will determine which inhibitor, if not both, is causing the problem.
- Adjusting the Brake Inhibitor(s).
- If an inhibitor is installed too tightly, it can trigger the inhibitor and stop the motor from working. To loosen the inhibitors, find the 2mm Allen key bolt and loosen it a turn or two. It can be found on the underside of the brake lever inhibitor housing near the adjuster bolt. Next, with a 7mm wrench, turn the inhibitor bolt 1 rotation to the left to pull it out a little.
- Test the adjustments. Once adjusted, test the bike functions again. If it didn't solve the issue, repeat steps 6 & 7 until it has solved the issue or the bolt has nearly fully come out of the housing.
- Retighten the Brake Inhibitor(s). If adjusting the Brake Inhibitor(s) solved the issue, remember to retighten the 2mm Allen key bolt so they stay securely in place.
How to Remove, Install, and Adjust Brake Inhibitors
If the error code does not resolve after performing the above troubleshooting steps, document the steps taken above with a video recording and Submit a Warranty Claim or Start a Ticket for Assistance.
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